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Bitmap Graphics Bitmap Graphics 

Bitmaps are created with lots of dots Vector graphics are defined with equations that 
specify lines, shapes, and locations 

Bitmap image is displayed on monitor with pixels Blank space does not have to be recorded 

Bitmap images cannot be scaled because of  
losing their quality or clarity 

Vector graphics are scalable 

Its files are big than vector graphics File sizes are usually smaller than bitmap file sizes 

 
Component of Flash Interface 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
Stage is the actual canvas in flash where all the objects to be included in a movie or animation are  
placed. It allows to the draw the graphics and preview the movie in design time. 
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Timeline : The Timeline is used to organize and control the contents of a movie over time in the layers 
and frames so that each movie instance can occur at the correct time. 
The major components of the Timeline are 
Layer Panel Normal Layer/Mask Layer/Guided Motion Layer 
Frames Blank Frames/Blank Key Frame/Key Frame/ End of Animation Frame 
Play-head.  
Tools on Time Line Onion Skin/Onion Skin Outlines/Frame Per Second/Current Frame Position 

               
Layer helps us to organize the artwork in your document. When we create a flash document it contain 
one layer but we can add more. Objects are placed in layer to create animation. 
Working with layers has several advantages: 
 You can draw and edit objects in one layer without affecting objects in another layer. 
 You can lock layers (to protect their embedded objects from unwanted editing) 
 You can hide layers, make them visible (i.e. you can see their objects in the workspace), or you    
     can  display just the outlines of their objects. 
 

 Different Types of Layer 
1. Normal Layer by default all layer added on time line are normal layers, which 
    means all objects on layer will appear on movie,   
2. Motion Guide Layer a motion guide layer contains an animation path that links to 
    an object on another layer. It is always added above the layer which is linked it is 
    not visible when we run the movie  
3. Mask Layer A mask is used to hide any layer linked to it. Only certain portions of 
    the underlying layer appear through mask design. While other parts of layer are 
     hidden or masked.  
4. Sound Layer: it is added automatically on timeline when we add sound on stage 
 
Inserting a New Layer  
Insert > Layer   or   Click “Insert Layer” icon  at bottom of layer panel     in Timeline 
 

• Copy Layer 
1. Click layer name to select the entire layer. 
2. Edit > Copy Frames. 
3. Click Add Layer button to create new layer. 
4. Select new layer and choose Edit > Paste Frames. 

• Copy Contents of Layer Folder 
1. Click triangle to left of folder name to collapse it, if necessary. 
2. Click folder name to select the entire folder. 
3. Edit > Copy Frames. 
4. Insert > Layer Folder to create new folder. 
5. Select new folder and choose Edit > Paste Frames. 

As we work with your animation, you can hide layers to prevent the stage from getting cluttered 
 we can lock layers to prevent accidental changes to the objects on them. 
To delete a layer, select it by clicking on the layer name and then clicking on the 
trash can icon    
 
 
 
 
A frame represents a particular instant in time and contains the content of the Stage at that instant 
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Key frames: Frames that define a change in what is displayed in a movie or include frame actions to 
modify a movie. When you open a new blank movie document, it contains one layer with one blank 
keyframe. Keyframe is denoted by black circle 
 
Blank Key frame indicates the beginning point for which there is no content on the layer. Blank Key 
frame is denoted by outline circle 
End of Content Sequence indicates the end point for which there is the same (or no) content on the 
layer  
 
Playhead- displayed as a red bar, identifies the current frame as it is displayed on the Stage. 
When the movie plays the playhead plays through the frames until all the frame content has been 
displayed. 
 
Frame rate: the speed of animation in measured in FPS (Frame Per Second) Frame rate tell how many 
frame will be covered/displayed in 1 Second. Default rate is 12fps 
 
A scene is a clip of a movie which can be treated as an entire single unit all on its own and 
arranged around other clips. The advantage of breaking the  movie into scenes is that every 
scene can be accessed individually and thus the sequence or order of scenes can be changed. 
 
Stroke: stroke is an outline of an image. Each image can consist of a stroke and a fill. To create a shape 
stroke and fill are two primary elements. 
Default stroke style: the default storke style is solid, meaning a solid line will be drawn. 
 
PANELS: panels are the small windows that let us to see and make change in the properties of objects 
and work with color, text, instances etc. 
Example: Properties panel, effect panel Library Panel, Color Panel 
 
The Property Inspector 
In the Property inspector, you can set the attributes of objects as you work. You will use the Property 
inspector frequently when working in Flash Professional 8. To open the Property inspector: 
 
Library panel is used to access, organize, and modify symbols in a document’s library. Symbols are 
stored in a document’s library. The library also stores imported bitmap images and sounds 
 
Symbol : A reusable graphical object that is stored in a Library.  You can then create multiple instances 
of the symbol.  There are three symbol types: graphic, button, and movie clip. 
 
Graphic Symbol Used for static images and to create reusable pieces of animation that are tied to the 
Timeline of the main movie 
 
Movie Clip  Symbol  Movie inside a movie.  On their own time, not necessarily in sync with the main 
timeline.Good for interactive things and sounds. 
 
Buttons  Symbol  Used to create interactive buttons in a movie that respond to mouse clicks or other 
actions. You define the graphics for each of the various button states, and then assign particular actions 
to an instance of a button. 
Instance of Symbol is copy of Symbol on Stage. All instances of a symbol share the same properties, 
animations, code, etc., but can be in different places and times on the timeline 
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Any change in Instance will not be reflected on Symbol . Any Change in Symbol will be automatically  
will be reflected in all instance 
 

The onion-skinning feature allows the designer to see multiple frames and how their movements      
relate to the current frame. When creating an animation, this feature can be a great help to see what 
the objects in the preceding and succeeding frames look like. 

 
The various selection tools available are: 

 Arrow tool : Used to grab, select and move items on the Stage. 

 Subselect tool : Displays edit points that can be adjusted to change the shape of a line. 

 Lasso tool: Used to select irregularly shaped object on the Stage. 
 

GAP SIZE: it is tool of paint bucket tool, when a shape without a fill has as outline that is not closed 
(such as a circular line with ends that do not meat); then the paint bucket uses Gap size modifier to fill 
the color. 

 
ALPHA VALUE: using alpha value we can add transparency effect to a color. At 100% alpha the color is 
opaque. All 0% the color is entirely transparent. The range in between affects the level of translucency 
the color has applied. 
 
A filter is a special graphic effect which can be applied to movie clips, buttons, and text 
Applied using the Filters section of the Property inspector Effects are -Drop shadow/Blur/ Glow 

 
Animation illusion of motion by creating a change over time (changing the contents of successive 
frames). Two Types of Animation 
1. Frame-by –Frame Animation       2.  Tween Animation 

Frame-by-frame animation Tweened animation  

 Flash animates object gradually over 
several consecutive frames 

 You can control action in every 
frame 

 Can be time-consuming and result in 
large file size 

 Flash automatically creates animation 
between two keyframes 

 You define starting and ending 
keyframes, then modify object/symbol 

 Types of tweens 
 Motion tweens 

 Shape tweens 

 

TWEENING: in tweening we select the starting and finishing points for an object and flash animates it by  
filling in between , tweened animation is called tweening. 

Motion Tweening Shape Tweening, 
In motion tweening, you define properties such as 
position, size, and rotation for an image, group, or 
text block at one point in time, and then you change 
those properties at another point in time.  

In shape tweening, you draw a shape at one 
point in time, and then you change that 
shape or draw another shape at another 
point in time. Flash interpolates the values 
or shapes for the frames in between, 
creating the animation 

Motion Tweening is done on Symbol or Group Shape Tweening is done on images/shapes not 
on symbol 

It is Denoted by Purple Grey Color on time line It is denoted by Green color on time line 
can also apply a motion tween along a Guided path. Cannot  apply a shape tween along a 

Guided path 
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Easing property is used  easing to speed up or slow down start or end of an animation 
 Object eases in: starts out slow, then speeds up at the end 
 Object eases out: starts out fast, then slows down 

 

 Publishing Formats :   swf, html,gif,jpg,png,mov,Windows Projector(.exe) macintosh Projector(.hqx) 
              Exporting Formats:    swf,avi,mov,jpg,gif,bmp,png,wav,wmf  
 

  Windows Projector(.exe) These are standalone format which can play on Windows Platform     
  without Flash Player installed 
  Macintosh Projector(.hqx) These are standalone format which can play on Mac(Apple) Platform   
  without Flash Player installed 
 
 
 
 
 
 
 
Publish Preview option: The Publish Preview option allows one to preview the movie in a browser 
before publishing to see if the movie is appearing fine 
 
Using Sound in Flash  
There are several ways to use sound in Flash. You can loop sounds to play continuously, independent of 
the timeline, or synchronize your sounds to an animation. You can import and edit your sounds in the 
Sound Panel. 

 
Importing 

Import sounds into Flash by choosing Import from the File menu. The following audio file formats 
can be imported into Flash: 

 WAV  
 AIFF  
 MP3  

If you have QuickTime 4 or higher, you can also import these file formats: 
 WAV (Macintosh and Windows)  

Flash stores audio files in the Library as a symbol along with the graphics, movies and buttons. Sound files 
are indicated by a loudspeaker icon. Because the sound is a symbol, you only need one copy of it and you 
can use it in many ways in your Flash movie. In the Library and on the Timeline, audio files are represented 
as sound waves.  

Publishing Exporting  

1. Publishing is preparing movie files 
and accompanying HTML codes 
for uploading movies on the 
Internet. 

2. Settings can be saved for reuse. 
3. A movie is published only if the 

recipients are expected to play it 
on the internet using Flash player . 

1. Exporting is saving a movie file in 
different formats to be played using a 
particular player. 
 

2. Settings cannot be saved. 
3. A movie is exported from Flash only if the 

recipients are expected to play it using 
software other than Flash . 

 

.FLA .SWF 
i) .FLA is the extension of the flash 
source file. 
ii) .FLA file can be opened and edited 
at any point of time 

i) .SW F is the extension of the flash publish 
file. 
ii) .SW F file cannot be edited, it can only be 
viewed. 
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Two types of sounds in Flash -- event sounds and stream sounds 

 Event sounds must download completely before they start playing and they will continue playing until 
explicitly stopped (usually by a stop action). Event sounds are associated with an event such as a mouse 
click, and are independent of the Timeline.  

 Stream sounds begin playing as soon as there's enough data to play. These sounds are synchronized to 
the timeline. Flash forces the animation to keep in sync with the sound. If it can't draw frames fast 
enough, Flash will drop frames to keep the sound in sync.  

Editing with the Sound Panel 

The Sound Panel allows you to modify the properties of the selected sound, for example: 
 specify if the sound is an Event or Stream  
 start a new sound, or Stop the sound  
 apply effects to the sounds, such as None (which strips any previous effects off the sound), Fade In or 

Out, Left to Right, etc.  
 If you choose Custom, you can modify the in and out points of the fade, the duration, etc. in the 

window that opens up. Click on the boxes at the corners of each channel and also add points along the 
line by clicking.  

 
Steps of Shape Tweening 

 Open up a new flash stage 

 Set the background colour 

 Set the frames per second rate 

 On the left hand side select the shape tool- draw a circle on you stage at frame 1 

 Select colour of your circle 

 Once drawn circle onto stage –go to key frame 30-press f6 button to insert key frame 

 In key frame 30 delete the shape that is there and instead using the rectangle draw tool draw out a 

rectangle 

 Select  a colour for the rectangle-make it different to the original circle 

 Choose any keyframe between 1 and 30 ideally 15-go to properties tab 

 Select shape tween 

 
Steps of Motion Tweening 

 Open up a new flash stage 

 Set the background colour 

 Set the frames per second rate 

 On the left hand side select the shape tool- draw a circle on you stage at frame 1 

 Select colour of your circle 

 Select Circle alongwith Stroke with the help of selection arrow tool.  

 Right click and choose  “Convert to symbol” option to convert circle to symbol/press F8 key to 

convert it to symbol 

 Go to key frame 30-press f6 button to insert key frame 

 In key frame 30  drag the Circle Symbol  to any other position . You can change the size of symbol by 

suing resize tool from tool box 

 Choose any keyframe between 1 and 30 ideally 15-Right Click and Select Motion Tween  
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Animating along a Guided Path 
Let's say you want a small airplane to follow a path from the ground up to the clouds. 

 Create a movie symbol of a little airplane with an animated propeller.  
 Drag the symbol out onto the stage. You may want to add a runway and some clouds in the sky to make 

your animation more complete.  
 Select the airplane layer and from the Insert menu, choose Motion Guide. This creates a new layer 

called a Guide Layer on top of the airplane layer.  
 Insert another keyframe in the Guide:airplane layer at the point where you want the motion to stop.  
 Using the Pencil tool, draw a curve that you want the airplane to follow from the runway to the clouds. 

(It won't show up in the movie)  
 Select the first keyframe in the airplane layer. Select the Arrow tool and move the airplane to the 

beginning of the curve.  
 Now select the last keyframe. Move the airplane along the curve to the end of the curve.  
 Double-click the first keyframe to open the Frame panel. Choose Motion from the Tweening menu and 

check Snap (snaps the registration point to the path).  
 Scrub along the Timeline, and the airplane will follow the curve from first to last frame. When you 

publish, the plane's propellers will move.  

 
 

Steps for Masking 

i. Draw an object , say a text “ learn flash 5.0 in 3 days” with the help of text tools on layer 1 at  

    frame 1st and press ctrl+g. ( Rename it Background layer by double click on Layer) 

ii. Select the frame 50. press F6 to make it KeyFrame 

iii. Click on insert new layer icon on layer panel , a layer will be created above the background layer. 

    Select the frame 1 of  new layer 2 ( Rename it mask layer by double click on lalyer)… 

iv. Draw a solid circle on the Mask layer at frame 1 and press F8 to convert it to Symbol 

v   Press F6 at  frame 50 to make it key Frame , move the circle symbol  to other side of stage     

     over the text  

v. Right click on any frame between 1 to 50 in mask layer and select create motion tween . 

vi. Right Click on Mask Layer at Layer Panel and choose “Mask”. It will make   Background layer 

disappear and masking is done 

vii Play the Movie by pressing Ctrl+ Enter Key 

 

 


